Firefox环境下使用Flash Player 9的debug版本[转] - IDC资讯网_站长学院 - Java PHP Flex Python Ajax CSS 编程 开源 学习 总结 分享
困扰N多人的问题,就是用Flex Builder 2或者3 Alpha进行debug的时候,如果你使用Firefox,则会遇到下面的状况:
你的Firefox已经安装了Flash Player 9 debugger version,但是Flex Builder缺提示说firefox没有安装flash player,要重新安装,重新安装后,成了标准版本的flash player,Flex Builder反而不能调试。以此往复,进入一个怪圈。

解决方法:
先去Adobe官方站点上下载一个Flash Player 9 Conntent Debugger for Nescape兼容的版本,安装
其次,找到以下2个路径:

c:\WINDOWS\system32\Macromed\Flash\
C:\Program Files\Mozilla Firefox\plugins\

将前者文件夹中的NPSWF32.dll复制到后者文件夹中。
最后,重新启动Flex Builder 2或者3 Alpha,在Window->Preferences->General->Web Browser里选定Firefox,就万事大吉了。

好处,使用Maxthon或IE进行标准Flash应用的浏览,使用Firefox进行Flex或AS3的debug及开发。两者互不影响,因为Firefox下进行flex及AS3开发不会出Buffer overflow的问题,而IE7则会出现此种情况。
Tags: , , , ,
编程语言 | 评论(0) | 引用(0) | 阅读(4135)